Asset list and asset details may not load or open

Minor incident Cloud Inventory Customisable Views Asset CRUD Duplicate conflicts
2026-08-26 17:42 CEST · 1 hour, 52 minutes

Updates

Resolved

Both issues have been fixed.

Systems are back to normal.

August 26, 2026 · 19:34 CEST
Investigating

Asset List issue has been resolved. We are still working on a fix for the Asset Detail issue.

Thank you for your patience.

August 26, 2026 · 19:00 CEST
Issue

We have identified an issue where sometimes the asset view and the asset detail may not load or open.

We apologize for any inconvenience.

August 26, 2026 · 17:42 CEST

← Back