Installers cannot be downloaded

Major incident Cloud Sync Linking Installation Status (Classic)
2026-07-01 15:35 CEST · 3 hours, 17 minutes, 1 second

Updates

Resolved

Incident has been resolved

July 1, 2026 · 18:51 CEST
Issue

We have identified an issue where the installers cannot be downloaded. We are working on a fix.

Sorry for the inconvenience.

July 1, 2026 · 18:29 CEST

← Back