Lansweeper Status
Subscribe
to updates
Reports are not being executed (EU Only)
Major incident
Cloud
Analytics
Reports
2025-05-15 15:27 CEST
· 4 hours, 3 minutes
Updates
Resolved
The issue has been resolved.
May 15, 2025 · 19:30 CEST
Issue
We have identified an issue and are working on a fix.
May 15, 2025 · 18:59 CEST
← Back