Users information in the Users section does not update

Minor incident Cloud Analytics Reports
2024-03-11 13:50 CEST · 3 days, 20 minutes

Updates

Resolved

Incident has been resolved. All systems are back to normal.

March 14, 2024 · 14:04 CEST
Investigating

We are investigating the issue and working on a fix.

March 14, 2024 · 13:20 CEST

← Back